01Nov

Support for version 3.x is discontinued

Starting with December 31st, 2013, Backup4all version 3.x. is no longer supported. If you are still using version 3.x we highly recommend an upgrade to the latest version.

Read More