06Nov

Support for version 2.x and 1.x is discontinued

END OF SUPPORT FOR VERSION 2.x and 1.x Starting with December 31st, 2010, Backup4all version 2.x and 1.x are no longer supported. If you are still using version 2.x or 1.x we highly recommend an upgrade to the latest version. …

Read More